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1 INTRODUCTION

This application note is intended to help developers who want to use BL654 module to develop applications using freely-available
tools and the Nordic SDK. The following are step-by-step instructions for setting up Eclipse, the ARM GCC compiler, and Nordic’s
nRF5x SDK. The ble_app_hrs example (which provides a peripheral heart rate service) is used to demonstrate how to build,
flash, and debug SDK applications on the BL654 development kit.

2 REQUIREMENTS

The following are required to complete this step-by-step guide: -

= Windows 7 (or newer) machine
=  BL654 Development kit (product code 455-00001 or 455-00002)
= USB A to micro USB cable (provided with BL654 development kit)

Note:  The following sections contain a step-by-step guide on obtaining and installing the other requirements listed below.
However, please note that the examples were completed and tested using the following:

= Nordic SDK v16.0.0

= nRFX-Command-Line-Tools v9.7.1

= Segger J-Link V6.20b

= Eclipse IDE for C/C++ Developers — Version: Juno Service Release 2 — Build: 20130225-0426
= GNU ARM Toolchain v8.3.1

=  GNU Make Utility v3.81

= CoreUtils for Windows

Although unlikely, any deviation from the above setup can cause issues in the build. For more information regarding
this, you can visit the Nordic tutorials on using SDK examples at:

https://devzone.nordicsemi.com/tutorials/7/development-with-gcc-and-eclipse/

3 DEVELOPMENT ENVIRONMENT SETUP

3.1 Nordic SDK

The Nordic Software Development Kit offers a rich development environment and examples for the BL654 module. It can easily
be used to develop applications for the BL654 when development using freely available software and C language is preferred.
The SDK offers a wide selection of drivers, libraries, and examples for the module and its peripherals.

To use Nordic’s SDK for BL654 development, complete the following steps:
1. Download the Nordic SDK zip file from https://www.nordicsemi.com/eng/Products/Bluetooth-low-energy/nRF5-SDK.
The file is located in the DOWNLOADS tab.

2. Once downloaded, extract and place the SDK in a suitable location on your machine, e.g.:
D:\Work\nRF5_SDK (Figure 1).
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Figure 1: nRF5 SDK folder structure

By default, the BL654 uses the nRF52840’s on-chip RC oscillator as its clock source, as opposed to the nRF52840
development kits which use an external crystal. The difference in oscillator source should therefore be reflected in the
SDK.

3. Open and edit the nRF5_SDK\components\softdevice\common\nrf_sdh.c file which is originally as shown in Figure 2.

S5 Motify observers ahout sSoftDevice enable request.
if (sdh_request_chserver_notify(MRF_SDH_EVT_EMABLE_REQUEST) == MRF_ERROR_EUSY)

S/ Enable process was stopped.
FETUrn MRF_SUCCESS;

3

A5 Motify ohservers about starting Softbevice enable process.
sdh_state_obhserver_notify(MRF_SDH_EVT_STATE_EMABLE_PREPARE];

nrf_clock_1f_cfg_t const clock_1f_cfg =

- s0urce = NRF_SDH_CLOCK_LF_SRC,

Lo ctiv = MRF_SDH_CLOCK_LF_RC_CTIV,
Lro_temp_ctiv = MRF_SDH_CLOCK_LF_RC_TEMP_CTIV,
S ACCUr Ay = NRF_SDH_CLOCK_LF_ACCURACY

1;

Figure 2: Original, unchanged nrf_sdh.c

4. Change the oscillator so that it uses the BL654 configuration as shown in Figure 3.

A4 Motify ohservers about softpevice enable request.
if (sdh_request_observer_notify(NRF_SDH_EVWT_EMABLE_REQUEST) == MRF_ERROR_EUSY)

A4 Enable process was stopped.
return MRF_SUCCESS;

A4 Motify ohservers about starting SoftbDewice enable process.
sdh_state_ohserver_notify(NRF_SDH_EVT_STATE_EMNABLE_PREPARE];

nrf_clock _1f_cfg_t const clock_1f_cfg =

. source = MRF_CLOCK_LF_SRC_RC,

Lro_ctiv = 14,

re_temp_ctiv = 2,

Laccuracy = MRF_CLOCK_LF_ACCURACY_S500_PPM

1

Figure 3: Changes to oscillator values in nrf_sdh.c
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3.2 nRFX-Command-Line-Tools

The nrfjprog is a command line tool used for erasing and flashing the BL654 with applications. The tool is bundled as part of the
nRF5x-Command-Line-Tools. You can install and setup the command line tools as follows:

Navigate to https://www.nordicsemi.com/Software-and-tools/Development-Tools/nRF-Command-Line-Tools

Select the Downloads tab.

Download the installer for your platform

Once downloaded, launch the executable. Proceed through the setup.

PN E

Note: During the setup process, you are prompted to install SEGGER J-Link. This is required for the command line
tools to work, so proceed by accepting and installing it.

5. Once downloaded, the nrfjprog executable can be found at C:\Program Files (x86)\Nordic Semiconductor\nrf5x\bin
(Figure 4).

Note: For 32-bit Windows installations, the location is:
C:\Program Files\Nordic Semiconductor\nrf5x\bin.

=N HE 5
W\ Program Files (xBENMordic SerniconductarinfSdhin - |4 | | Search bin P |
Organize = Include in library - Share with - Burn Mew folder ==« [l I@
30 Favorites —y Mame Type &
Bl Desktop L docs File folder
i Downloads L headers File falder
"l Recent Places 2 & jlinkarrr_nef31_nrfjprog.dil Spplication extension
& Jlinkarn_nefa2_nifjprog.dl Anplication extension
- Libraries 55 rmergehex.exe Spplication
[ Documents & misvcpd00.dI Bpplication extension
J" husic ) miswecr100.dll Application extension
[ Pictures %) nefjprog.dil Application extension
B videos [ nrfjprog.exe Lpplication
#  nifjprog.ini Caonfiguration settings
1M Cormputer - 4| 1 | r
] 10 items
Figure 4: Location of nrfjprog.exe
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3.3 Eclipse

Eclipse is a universal, highly customizable IDE, C code browser, and an efficient editor. It is a free software based on Java.
Please note that it is important to download the package that comes with the CDT C/C++ development tools plugin. Usually no
installation is required for Eclipse. Once downloaded (and unzipped), eclipse.exe can be launched straight away.

3.3.1 Eclipse Initial Setup

The following steps are required to setup Eclipse appropriately:
1. If not already installed, download and install the Java Runtime Environment from http://www.java.com

For 64-bit systems, please ensure that the bit-version of java matches that of eclipse, i.e. both should be 32-bit
or 64-bit.

Note:

2. Download the Eclipse IDE for C/C++ from http://www.eclipse.org/downloads/packages/eclipse-ide-cc-
developers/junosr2 (the download link should appear on the right-hand-side of the web page)

There are many different packages and types of Eclipse and each has its unique features and goes through a
different installation process. While all packages should work similarly, the installation of the juno package is
highly recommended, as it is used for the examples in this guide.

Note:

3. Extract the zip file into a folder in the same download location.

4. Move the folder to a known location, e.g.:
D:\Work\Eclipse (Figure 5).

Figure 5: Location of eclipse.exe
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5. Once moved, launch the Eclipse executable (Application). Use the default Workspace when prompted (Figure 6).

W ——

= Workspace Launcher . e W W — u
eee— —

Select a workspace

Eclipse stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session,

LRGNt Users! Laird\workspace

[] Use this as the default and do not ask again

Figure 6: Eclipse default workspace

3.3.2 Eclipse Debugging Tools

To install the Eclipse hardware GDB tools, complete the following steps:

1. From Eclipse, click Help > Install New Software (Figure 7).

P— T |

@ brotsl

Avallable Software

Sedect a site or enter the location of 2 site.

ok wioe" STETTRITITEN [ ase |
Find more software by working with the ~&wvailable Software Sites” preferences.

type Fiter bext

HName Wersion

[0 There is no site selected.

[ soeass || peeecss |

Dretsils
& Show arly the et verpont of svailable icfwane | Hsde #ern that are aloesdy mitalled
i irowp e by category What i gleeady installed?

] Show orly software spplicable to target emvircnment
o Contact ol updete sites during iratall 1o find requined scftware

'f_?:] < Bach Mt Einksh [ Cancel

Figure 7: New Software installation window

2. Add the following URL to the repository list (the field labeled Work with):
http://download.eclipse.org/tools/cdt/releases/juno. The main items window will populate with new software packages

from this repository.
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3. Check CDT Main Features and GDB Hardware Debugging (Figure 8).

| type filter text |
Narne Version i
i [] 000 CDT Main Features =
4 [H] 000 COT Optional Features
"?:p Autotools support for COT 3.01.201302132326
% Autotoels support for COT Source 3.01.201302132326
% C/C++ Debugger Services Framework (DSF) Examples 21.0.201302132326
"?:p C/C++ GCC Cross Compiler Support 11.0.201302132326
% C/C++ GDB Hardware Debugging 7.00.201302132326
“?:p C/C++ Memory View Enhancements 2.20.201302132326 ¥
| SelectAll || Deselectall 3 items selected

Figure 8: New software selected

4. Click Next.
5. Proceed through the installation by clicking Next in the windows that follow (Figure 9).
® ot . - ErEr=—~=)
Install Details
(@ Your original request has been modified. See the details. o
Name Vession i
@ C/Ce» Development Tocks 812201302132326  org.ecipse.cdt.festure.group
G C/Ce Development Tooks SOK 812201302132326  ceg.echpsecdtsdifesture.group
g} C/Ce+ GDB Hardware Debuggng TOQ01032832%  oegechpsecdt.debug gdbstag festure.gro.
. m " »
Size: Unknown
Details
Your criginal request has been modified.
“C/Ce« Development Tools” is already installed, 50 an update will be performed mnstead.
@ shea. o] | #nen | [Conce ]

Figure 9: Completing installation

6. Once the installation is complete, you might need to restart Eclipse for the changes to take effect.

3.3.3 Eclipse Embedded System Register View

To install the embedded system register view, complete the following steps:

1. From Eclipse, click Help > Install New Software.

2. Add the following URL to the repository list (the field labeled Work with): http://embsysregview.sourceforge.net/update.
The main items window populates with new software packages from this repository.

Note: If embsysregview does not appear in the window, your firewall may be preventing you from accessing the
download page. Please check your firewall settings.

3. Select and install embsysregview (Figure 10).
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Work wath:  hitpy//embsysregview.sourceforge.net/update - Add
Find mare seftware by working with the “Aupilable Software Sites” preferences. |

type filter text
Name Wersion
] B embaysregies

| seiectan || Deseiectan | 1item selected

Figure 10: Installing embsysregview

Click Next.
Proceed through the installation.
Once the installation is complete, you might need to restart Eclipse for the changes to take effect.
To install the register view file for Nordic Semiconductor devices, copy file nrf52840.svd as follows:
= From: \nRF5_SDK\modules\nrix\mdk
= To: \eclipse\plugins\org.eclipse.cdt.embsysregview_<version>/data/SVD(CMSIS)\Nordic

No o s

You may need to create the Nordic folder if it does not already exist.

3.4 GNU ARM Toolchain Setup

The GNU ARM toolchain contains tools for building and debugging the project, such as GCC and GDB. To setup the toolchain,
complete the following steps:

1. Download the installer package for your operating system from the following link:
https://developer.arm.com/tools-and-software/open-source-software/developer-tools/gnu-toolchain/gnu-rm/downloads

2. Launch the executable.
3. Select the Destination folder to be a known location, e.g.: D:\Work\Tools\ARM_GNU

& GNU Tools for Arm Embedded Processors 9-2019-g4-major o ] 5|

Choose Install Location —

Choose the Folder in which to install GMU Tools For Arm Embedded Processors Y
9-2019-g4-major 9 2019,

Setup will install GMU Tools for Arm Embedded Processors 9-2019-g4-major 9 2019 in the
fallowing Falder. To install in a different Folder, dlick Browse and select another Folder, Click
Install bo start the installation,

EBrowse. ., |

"Destination Folder

Space required: 498, 9MB

fullsaft Install System « 2, 46-7

< Back. I Install I Cancel

Figure 11: Installing GNU Tools for ARM Embedded Processors

4. Select Install.

To use the toolchain executables from any directory, their location needs to be added to the PATH environment variable. Add
the executables to the PATH environment variable by doing the following:

1. Right-click Computer > Properties.

2. Select Advanced system settings.

3. Select Environment Variables.

4. Inthe System variables section, select Path and click Edit...
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5. Add the location of the GNU ARM executables preceded by a semicolon (;), e.g.:
;D:\Work\Tools\ARM_GNU\bin

6. Open the command prompt (if already open, cmd must be reopened) and confirm that the ARM toolchain is set up
correctly by typing:

{ arm-none-eabi-gcc —-version

The above command should return the version number of ARM GCC. If it doesn’t, then this means that the ARM toolchain
location was not added to the PATH variable successfully (Figure 12).

[z Administrator: ChWindows' system 32 cmd.exe

C:~UWindows~System3Z2>arm—none—eabi—gcc.exe —wversion
arm—none—eabi—gcc.exe (GHU Tools for Arm Embedded Processors 8-28019—g3-update)> 8

3.1 20198783 <release? [gcc—8-branch revision 2738271

Copyright <C> 2018 Free BSoftware Foundation. Inc.

Thizs is free software; see the source for copying conditions. There iz HNHO
warranty; not even for MERCHAWNTABILITY or FITHESS FOR A PARTICULAR PURPOSE.

Figure 12: Using ARM GCC through the command prompt

The location and version of the ARM GNU toolchain executables also need to be added as a one-off setup to be used by the
Nordic Makefiles. To do this, complete the following steps:

1. Open the file D:\Work\nRF5_SDK\components\toolchain\gcc\Makefile.windows

2. For GNU_INSTALL_ROOQOT, add the location of the ‘bin’ folder, e.g.:
D:/Work/Tools/ARM_GNUY/)

3. For GNU_VERSION, add the version of the toolchain (obtained from Step 7 above), e.g. 8.3.1.

B Makefile.windows - Notepad

File Edit Format Wiew Help

GHU_IMSTALL_ROOT 1= C: work/Tools arRM_SHUs
GMU_WERSION := B.3.1
GHU_PREFIX := arm-none-eakd

Figure 13: Adding ARM GCC to Makefile.windows

3.5 GNU Make Utility Setup

The GNU Make Utility allows the build of the project using a Makefile. This means that project settings in Eclipse will not affect
the build process and that the project is self-contained through the Makefile. To setup the Make utility, complete the following
steps:

1. Download the Windows installer file from the following link: https://sourceforge.net/projects/gnuwin32/files/make/

2. Launch the executable

3. Select the Destination Location to be a known folder, e.g.: D:\Work\Tools\Make (Figure 14)

F Bl
i_i' Setup - Make Elilg
Select Destination Location ¥
Where should Make be installed? P, e

l Setup will install Make into the following folder.

To continue, click Mext. f you would like to select a differert folder, click Browse.

D\ Work\Tools \Make Browse...

At least 0.7 ME of free disk space is required.

<Back || Ned> | [ Cancel

b

Figure 14: Installing Make utility
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4. Proceed through the installation by clicking Next until the installation is complete.

Note: Some versions of MAKE prompt you to add the toolchains to the PATH variable. If this is the case, then select
this option and skip to the next section.

To use Make from any folder, add the GNU Make executable to the PATH environment variable by doing the following:

Right-click Computer > Properties.

Select Advanced system settings.

Select Environment Variables.

In the System variables section, select Path and click Edit...

Add the location of the GNU Make utility executable preceded by a semicolon (;), e.g.:
;D:\Work\Tools\GnuWin32\bin

6. Open the command prompt (if already open, cmd must be reopened) and confirm that Make is set up correctly by
typing:

i make —--version |

akrwbdpR

The above command should return the version number of make. If it doesn’t, then this means that the make executable
location was not added to the PATH variable successfully (Figure 15).

B Administrator: Windows Command Processor o | = | &8

oL

for HI

am built for i3BE-—pc-mingu:

Figure 15: Using GNU Make through the command prompt

3.6 GNU CoreUtils for Windows

Due to the use of UNIX shell commands in the SDK makefiles, the GNU CoreUtils package must be installed for these commands
to work. To do this, complete the following steps:

1. Download the CoreUtils Binaries zip file from http://gnuwin32.sourceforge.net/packages/coreutils.htm
2. Extract the files into a known folder, e.g.: D:\Work\Tools\CoreUtils

(=N (o >
—
@'\J"l W ok Tl Core L lsheoreutils-5.3.0-bin - | 43 || search coreutits-5.3.0-bin ol
Organize « Include in library = Share with = Burn Mew folder =« O I@I
W Favorites Marne Type
Bl Desktop . hin File folder
& Downloads 3 . contrib File folder )
15l Recent Places . tnan File folder select '?.fll'.itc
4 preview.
. tnanifest File folder
o Libraries . share File folder
E PN | 1| i C
5 items
Figure 16: CoreUtils binaries location
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To use CoreUtils from any folder, add the GNU CoreUtils binaries to the PATH environment variable by doing the following:

Right-click Computer > Properties.

Select Advanced system settings.

Select Environment Variables.

In the System variables section, select Path and click Edit...

Add the location of the GNU Make utility executable preceded by a semicolon (;), e.g.:
;D:\Work\Tools\CoreUtils\coreutils-5.4.0-bin\bin

6. Open the command prompt (if already open, cmd must be reopened) and confirm that the CoreUtils are set up correctly
by typing:

rm —--version

akrownpE

The above command should return the version number of rm. If it doesn’t, then this means that the CoreUtils binaries
location was not added to the PATH variable successfully (Figure 17).

B Administrator: Windows Command Processor E\@

C-sWindowssS8ystem32>rm ——version
rm (GMU coreutils> 5.3.8
Written by Paul Rubin, David MacHenzie. Richard Stallman. and Jim Mevyering.

Copyright (C» 2005 Free Software Foundation, Inc.
Thiz iz free software; see the source for copying conditions. There iz NO
warrantys; not even for MERCHANTABILITY ox FITMESS FOR A PARTICULAR PURPOSE.

C=Windows~System32>

Figure 17: Using CoreUtils through the command prompt

4 BUILDING AND DEBUGGING SDK EXAMPLES
4.1 Example of Building the HRS

In the next steps, we import and configure an existing HRS application. This sample HRS application comes as part of the nRF5
SDK.

1. Launch Eclipse.

2. Create a new project by selecting File > New > C Project.

3. Inthe Project name field, type hrs.

4. From the Project type section, select Makefile project > Empty Project. In the Toolchains section select — Other

Toolchain —.
5. Click Finish. The project should now appear on the Project Explorer tab on the left (Figure 18).
F ™y
& C/C++ - Eclipse =
File Edit Source Refactor Navigate Search Project Run Window Help
= R RS SR SERIE R AR AR A CESE S A B AU N
e li= Lt g T Quick Access | % |[Eacs)
[ Project Explorer 53 | = 0 » =8
E&|e ¥ ® 7
>[5 hrs| An outline is
not available.
[B Proble.. 57 02 Tasks Console Prope = B8
b

Figure 18: Creating project in Eclipse

6. Right click on the project (hrs) and select New->Folder.
7. Click the Advanced button at the bottom of the Window.

https://www.lairdconnect.com 10 Americas: +1-800-492-2320
© Copyright 2019 Laird Connectivity. All Rights Reserved Europe: +44-1628-858-940
Hong Kong: +852 2923 0610



Using the BL654 and Nordic SDK v16.0.0 with Eclipse and

GCC LairdT J» CONNECTIVITY

Application Note

8. Select Link to alternate location (Linked Folder) and browse to the location of the hrs project, e.g.:
D:\Work\nRF5_SDK\examples\ble_peripheral\ble_app_hrs (Figure 19).

Folder name: ble_app_hrs

) [= Use default location
(C) [, Folder is not located in the file system (Virtual Folder)
@ [ Link to alternate location (Linked Folder)

DWarkh\nRFS_SDK\examplesible_peripheral\ble_app_hrs E Browse... ” Variables...

Choose file system:

Figure 19: Adding files and folders to the project

9. The header and source files should now appear within the project (Figure 20).

= C/Car - Eclipse . . . 3]

File Edit Source Refactor Mavigate Search Project Run  Window Help

i A EREREN R A A RN AR AR A RS SR A P R AR SR Sl B =l SN

I Y v‘ ol Quick Access ‘J i} |
[ Project Explorer 53 = B8 = B @ ® =8
<'==={>‘ - I e -
4 25 hrs An outline is not
P |ﬁ ble_app_hrs| available.
> = hex

[ (= pcal0040

[+ = pcal0040e

[» = pcal0056

I (= pcal0059

[ main.c
ble_app_hrs.eww

E_gProbIerns 22 & Tasks B Console B Properties ¢ T =08
0 items

« ST 3

Figure 20: Project files and folders added in Project Explorer

10. Right-click on the project (hrs) and select Properties. Select the C/C++ Build section.

11. Under the Builder Settings tab In the Build directory field, type the location of the Makefile that is used to build the
project, e.g.:
D:\Work\nRF5_SDK\examples\ble_peripheral\ble_app_hrs\pcal0056\s140\armgcc (Figure 21).
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.

= Properties for hrs [=[=@ | =]
type filter text C/C++ Build [T =

i Resource

Builders
&> Cf/C++ Build Configuration: [Defaui‘l [ Active ] '] [Mal\age Configurations...
[ CfC++ General

Project References

Run/Debug Settings [Z] Builder Settings | Behaviour céh Refresh Policy
1> Task Repository

WikiText Builder

Builder type: ‘External builder v|

Use default build command

Build command: ‘ make | |Variab|es...|

Makefile generation
[ Generate Makefiles automatically [/] Expand Env. Variable Refs in Makefiles

Build location
Build directory:  D:\Work\nRF5_SDK\examples\ble_peripheralible_app_hrs\pcal0056\s140harmgcc

Workspace... ] [ File system... ] [Valiabls... ]

[ Restore Defaults ] [ Apply ]

@ [ ok J[ canca |

Figure 21: Adding Makefile location to project properties

12. Select OK.
13. You can now build the project by clicking Project > Build All. Alternatively, click the Build button or CTRL+B.
14. Once the project is built, the hex and binary files are generated as shown in the figure below (Figure 22).

El Console 52 | [%{ Problems 2| Tasks = Properties 4L 9P | = E“| =B~y = 08
CDT Build Console [hrs]
Compiling file: nrf_sdh_ble.c e

Compiling file: nrf_sdh_soc.c
Linking target: _build/nrf52848 xxaa.out
text data bss dec hex filename
58816 384 4852 62372 f3a4 _build/nrf52848 xxaa.out
Preparing: _build/nrf52848 xxaa.hex
Preparing: _build/nrfS2848 xxaa.bin

DONE nrf52848_xxaa 3
15:28:48 Build Finished (tecck 32s.898ms) -
Figure 22: Building the HRS example
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4.2 Flashing the HRS example

Connect the BL654 to the PC through USB2 port on the development kit (Figure 23).

v
L

me

*

s J-Link Technology »

Figure 23: Connecting BL654 to PC through USB2 port

Flash downloading to the BL654 must be performed through the external toolchain configuration in Eclipse. For the hrs project,
four external commands need to be added:

4.2.1 Erase

1. In Eclipse, select Run > External Tools > External Tools Configuration...

2. Right click Program > New. In the Name field type Erase.

3. Inthe Location field, type the path of the latest version of nrfjprog.exe. This is usually located in the Nordic
Semiconductor folder in Program Files e.qg.:
C:\Program Files (x86)\Nordic Semiconductor\nrf5x\bin\nrfjprog.exe

4. Inthe Arguments field, type -f NRF52 --eraseall

Switch to the Build tab and deselect Build before launch.

6. Click Apply, then click Run (Figure 24).

o
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& External Tools Configurations E

Create, manage, and run configurations 0

Run a program ~ |

G B xl i Marne:  Erase
|| | E| hlain Q{}"‘* Refresh\l Build\l [ -] Environmenq i=| Common\I

4 '@, Program Location: -l
Q Erase ChProgram Files Gd6hMordic Semiconductorindfdbininrfjprog.exe
[Browse Wnrkspace...] lBrnwse File System...] l Wariables.., ]

m

Woarking Directony:

[Browse Wnrkspace...] lBrnwse File System...] l Wariables.., ] B

Argurnents:
--eraseal| -f nrf52 - 8
| Rewert | | Apply |

Filter matched 2 of 2 items

@ I Run I l Clase ]

Figure 24: Adding Erase to External Tools Configurations

4.2.2 Flash Softdevice

1. Select Run > External Tools > External Tools Configuration...
Right click on Program > New. In the Name field, type Flash_Softdevice.
3. Inthe Location field, type the path of the latest version of nrfjprog.exe. This is usually located in the Nordic

Semiconductor folder in Program Files e.qg.:
C:\Program Files (x86)\Nordic Semiconductor\nrf5x\bin\nrfjprog.exe

4. Inthe Working Directory, enter the directory where the hex file of the softdevice is located. This is located in
D:\Work\nRF5_SDK\components\softdevice\s140\hex
5. Inthe Arguments field, enter the --program command followed by the name of the hex file and the device family

argument. e.g.:
-f NRF52 --program s140_nrf52_7.0.1_softdevice.hex

6. Switch to the Build tab and deselect Build before launch.
7. Click Apply, then click Run (Figure 25).

n
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I Create, ge, and run fig

€3 External tool working directory does not exist or is invalid

El &l 3 | MName: Flash_softdevice
type filter text % PMain Qé'\‘ Refre;hw Bui\:q E Environmenq E gommoﬂ
L] q Program Location: =
Q@ Erase . " - . y
. ChProgram Files\Mordic Semiconductornf5x\bin‘\nrfjprog.exe
@, New_config
[BlcmseWaprace...l [Bmwsg FileS_‘,‘Stem...l [ Variables... ]

m

Working Directory:
DWorkh\nRF5_SDK\ componentssoftdevicets1 40\ hex

[BmwseWulbpace...l [Bmwse Fileﬁystem...l [ Variables... ]
Arguments: |
-f NRF52 --program s140_nrf52_7.0.1_softdevice.hex -
s -
4 LI} |
e

Filter matched 3 of 3 ite

@ ‘ Run | [ Close I

\

Figure 25: Adding Flash_softdevice to External Tools Configurations

4.2.3 Flash BL654

1. Select Run > External Tools > External Tools Configuration...
Right-click Program > New. In the Name field type Flash_hrs.
3. Inthe Location field, type the path of the latest version of nrfjprog.exe. This is usually located in the Nordic

Semiconductor folder in Program Files e.g.:
C:\Program Files (x86)\Nordic Semiconductor\nrf5x\bin\nrfjprog.exe

4. Inthe Working Directory, enter the name of where the generated *.hex file is located, e.g.:
D:\Work\nRF5_SDK\examples\ble_peripheral\ble_app_hrs\pcal0056\s140\armgcc\_build

5. Inthe Arguments field, type command used for programming the devkit. E.g.:
-f NRF52 --program nrf52840_xxaa.hex

6. Switch to the Build tab and deselect Build before launch.
7. Click Apply and then Run.

& External Tools Configurations @

n

£

Create, ge, and run config

Run a program |

T = Y
OBE X ‘ - MName: Flash_hrs
‘tyPE filter text | =] main o Rafresh} Bull:ﬂ s Enwronmenﬂ =) Qommorﬂ
4 @ Program Location: -
q Erase C:\Program Files (x86)\Mordic Semiconductor\nSx\bin\nrfjprog.exe
Q., Flash_hrs
q Flash_softdevice [Bmwse Wolkspace...] lewsg File S_',rstem...] [ Variables...

Werking Directory:
D:A\Work\nRF5_5DK\examplesble_peripheral\ble_app_hrs\pcal00564s140harmgec_build

Browse Wolkspace...] [ Browse File Sys'(:m...] [ Variables...
Arguments:
-f MRF52 --program nrf52840_e@a.hex o
Filter matched 4 of 4 items | =) | | Aeply |
® l Bun I l Close ]

Figure 26: Adding Flash_hrs to External Tools Configurations
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4.2.4 Reset

1. Select Run > External Tools > External Tools Configuration...
Right-click Program > New. In the Name field type Reset.
3. Inthe Location field, type the path of the latest version of nrfjprog.exe. This is usually located in the Nordic

Semiconductor folder in Program Files e.g.:
C:\Program Files (x86)\Nordic Semiconductor\nrf5x\bin\nrfjprog.exe

4. Inthe Arguments field, type -f NRF52 --reset
Switch to the Build tab and deselect Build before launch.
6. Click Apply and then click Run (Figure 27).

g External Teols Configurations E

Create, manage, and run configurations 0

N

o1

Run a program ~ |

EIE:E]x|}:=>v Mame: Reset

|t.‘!'FEﬁ|tE’ text | =] Main o F‘.efresh} Build\l - -] Environmenﬂ i=| Commorﬂ
4 @ Program Lacation: il
G Erase CH\P Files (x86)\Nordic SemiconductorinrfSx\bin\nrfj
q F|35h hrs . rogram I Es( :] ordic semiconductoryn FAN eyl Jpl’og.a(e
Flash_softdevice Browse Workspace... | | Browse File Eem... Variables...
) pa
q Reset g

Working Directory:

l Browse kaspace...l l Browse File System...] l Vanables... ]
Arguments:
-f MRF52 --reset B il
() F——
| Revert | | Apply |

Filter matched 5 of 5 items

@ [ Run ][ Close |

Figure 27: Adding Reset to External Tools Configurations

Once this is done and setup, you can now erase and flash the hrs app onto the module as follows:
1. Run > External Tools > Erase
2. Run > External Tools > Flash_Softdevice
3. Run > External Tools > Flash_hrs
4. Run > External Tools > Reset

Alternatively, the shortcut button for external tool configuration can be used.
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4.3 Debugging the HRS Example

Debugging an application on the BL654 allows you to see what is going on inside the program while it runs. This can help detect
problems and issues, as well as show the values of the variables and the flow of the program at different stages. In order to
debug the hrs application, complete the following steps:

1. In Eclipse, select Run > Debug Configurations
2. Right click GDB-SEGGER J-Link Debugging > New

Note: If GDB SEGGER J-Link Debugging does not appear as one of the Debug Configurations options, then it has
not been installed properly as part of NnRF5x-Command-Line-Tools. You might need to install the J-Link
Software from https://www.segger.com/downloads/jlink. Also ensure that the Eclipse Debugging Tools are
installed properly.

w

In the Name field, specify the name of the debugging option, e.g. hrs.

In the Project field, specify the name of the project being debugged, e.qg. hrs.

5. Inthe C/C++ Application field, provide the location of the *.out file. This is usually in the _build folder of the SDK
example, e.g.:
D:/Work/nRF5_SDK/examples/ble_peripheral/ble_app_hrs/pcal0056/s140/armgcc/_build/nrf52840 xxaa.out

6. Select Disable auto build (Figure 28).

»

2 Debug Configurations

Create, ge, and run config
LAE:EIK|:{=:">v MName: hrs
|t)rpefiltertext | Main %5 Debuggeﬂ -3 Startup} B Source} is] gommon] &, SVD Path}
. i

€] €/C++ Application o Project: it
[©] C/C++ Attach to Application
[€] €/C++ Postmortem Debugger hrs Browse...
[£] C/C++ Remote Application C/C++ Application:

i+ [&] GDB Hardware Debugging
[c] GDB OpenOCD Debugging
[€] GDB PyOCD Debugging Variables... ] [Sealcl_'\ Plo)ect...] [ Browse... ]
[c] GDB QEMU Debugging

4 [c] GDB SEGGER J-Link Debugging

hrs Build Configuration: | Select Automatically v]
= Launch Group

D:\Work\nRF5_SDK\examplesi\ble_peripheralible_app_hrs\pcal0056's1400armgect_build\nrf52840 _ecaa.out

m

Build (if required) before launching

() Enable auto build @ Disable auto build
() Use workspace settings Configure Workspace Settings... i
Revert Apply
Filter matched 12 of 26 items | = ‘ | LEBY ‘
® | Debug | [ Close ]

Figure 28: Debug Configurations for the hrs app

7. Switch to the Debugger tab.

In the Device name, enter Cortex-M4.

9. Scroll down until you see GDB Client Setup.

10. In the Executable field, enter the following: arm-none-eabi-gdb.exe (Figure 29).

®

Note: If there is more than one device connected, ensure that the BL654’s Segger Serial Number is specified in the
USB serial field in the Debugger tab.
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g Debug Configurations E

Create, ge, and run config ions

DEE]*'Z%:&' Name:  hrs

|t}"pE filter text | Main ﬁ;& Debugger @ Startup] E_p Snurce] i=| Cnmmnn]
[©] CfC++ Application J-Link GDE Server Setup |l
[E] C/C++ Attach to Application [] Start the J-Link GDB server locally [7] Connect to running target

++ Postmortern Debugger
[E] CfCesP Debugg

[T] C/C++ Remote Application Executable: $jlink_path}/${jlink_gdbsenver} Browse... | | Wariables.,

[€] GDB Hardware Debugging

[£] DB OpenOCD Debuggi Dewvice name:  Cortex-M4 Supported device narns
[©] GDB QE::U |:|ebu;9iungggmg Endlanness: o S
4 [T GDB SEGGER J-Link Debugging Cannection: @1 453011443 (LUSE setial or IP name/address)
[E] hrs Interface: © 174G

B Launch Group Initial speed: () Auto () Adaptive @) Fixed W kHz
GDE paort: ?
S0 port: 2332 [¥] Werify downloads  [¥] Initialize registers an star
Telnet port: ? [7] Lacal host anly [T Silent

Log file: Browse..|

Other options:  -singlerun -strict -timeout [ -nogui

[¥] &llacate console forthe GOB server [7] &llacate console for semihosting and SW0

GDE Client Setup

Executable: arm-none-eabi-gdb.exe Browvse... | | Wariahles.,

Cther options:

Commands:  set mem inaccessible-by-default off )

Rermote Target

Host narme or [P address:
Part number: 2331 m

Farce thread list update on suspend

4 I | Y

4 T 3 |
Filter matched 10 of 15 iterms

Rewert | | Apply |

® l Debug I [ Close I

Figure 29: Debugger tab in the Debug Configurations for the hrs app

11. Click Apply, then click Debug.

12. You should now be in the debug view. You can step over, step into, and add breakpoints through the Run from the
toolbar (Figure 30).
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1018

1219 /**@brief Function for application main entry.
1020 */

221 int main(void)

@23 bool erase_bonds;

225 ff Initialize.

226 log init();

@27 timers_init();

@28 buttons_leds_init{&erase_bonds);
229 ble_stack_init();

230 gap_params_init();

@31 gatt_init();

@32 advertising init();

@33 services_init();

234 sensor_simulator_init();
@35 conn_params_init();

@36 peer_manager_init();

238 /f Start execution.
@39 NRF_LOG_INFO("Heart Rate Sensor example started.");
240 application_timers_start();

242 advertising start(erase_bonds);

244 /f Enter main loop.

245 for (;;)

246 {

247 if (NRF_LOG_PROCESS() == false)
048 {

249 power_manage();

Figure 30: Debugging hrs application

5 REFERENCE

Further information relating to different utilities used in this app note can be found here:

=  BL654 Product Page - https://www.lairdconnect.com/wireless-modules/bluetooth-modules/bluetooth-5-modules/bl654-
series-bluetooth-module-nfc

=  Make - https://www.gnu.org/software/make/

= ARM Toolchain - https://launchpad.net/gcc-arm-embedded

=  Eclipse - https://eclipse.org/org/

=  Nordic Tutorial on using Eclipse and GCC - https://devzone.nordicsemi.com/tutorials/b/getting-
started/posts/development-with-gcc-and-eclipse

= Nordic Blog on using Eclipse and GCC - hitps://devzone.nordicsemi.com/b/blog/posts/development-with-eclipse-and-gcc
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